// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)(?:\s*<br[^>]*>\s*){3,}").unwrap();
let string = "<br>
<br>
<br>
High Quality Print<br>
<br><br>
<br><br>
<br>
Data<br>
<br>
<br>
<br>";
let substitution = "<br><br>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}