$re = '/(?:\s*<br[^>]*>\s*){3,}/s';
$str = '<br>
<br>
<br>
High Quality Print<br>
<br><br>
<br><br>
<br>
Data<br>
<br>
<br>
<br>';
$subst = "<br><br>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;