# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\s*<br[^>]*>\s*){3,}"
test_str = ("<br>\n"
" <br>\n"
"<br>\n"
" High Quality Print<br>\n"
"<br><br>\n"
" <br><br>\n"
"<br>\n"
" Data<br>\n"
"<br>\n"
" <br>\n"
"<br>")
subst = "<br><br>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.