use strict;
my $str = '<br>
<br>
<br>
High Quality Print<br>
<br><br>
<br><br>
<br>
Data<br>
<br>
<br>
<br>';
my $regex = qr/(?:\s*<br[^>]*>\s*){3,}/sp;
my $subst = '<br><br>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";