re = /(?:\s*<br[^>]*>\s*){3,}/
str = '<br>
<br>
<br>
High Quality Print<br>
<br><br>
<br><br>
<br>
Data<br>
<br>
<br>
<br>'
subst = '<br><br>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result