# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((["'])(?:(?=(\\?))\3.)*?),\2/$1"/g;t' <<< "1070,17,2,GN3-670,\"COLLAR B, M STAY,\",\"2,606.45\" "