re = /((["'])(?:(?=(\\?))\3.)*?),\2/
str = '1070,17,2,GN3-670,"COLLAR B, M STAY,","2,606.45" '
subst = '$1"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result