import Foundation
let pattern = #"((["'])(?:(?=(\\?))\3.)*?),\2"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1070,17,2,GN3-670,"COLLAR B, M STAY,","2,606.45" "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)