use strict;
my $str = '1070,17,2,GN3-670,"COLLAR B, M STAY,","2,606.45" ';
my $regex = qr/((["'])(?:(?=(\\?))\3.)*?),\2/p;
my $subst = '$1"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";