const regex = /((["'])(?:(?=(\\?))\3.)*?),\2/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((["\'])(?:(?=(\\\\?))\\3.)*?),\\2', 'g')
const str = `1070,17,2,GN3-670,"COLLAR B, M STAY,","2,606.45" `;
const subst = `$1"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);