#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)<a[^>]+href=["'](?P<link>.*?)["']*.?> match this text\."
Local $sString = "<html><body>" & @CRLF & _
"This is the start. " & @CRLF & _
"<a href="http://example.com/path">We don't want to match this text.</a>" & @CRLF & _
"<a href="http://www.example.com/another/path" style="font-family:Arial, Helvetica, 'sans-serif'; color:#838383;font-size:12px; line-height:14px"></a> match this text.<a href="blah">We also don't want to match this text</a>" & @CRLF & _
"</body></html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")