using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?is)<a[^>]+href=[""'](?P<link>.*?)[""']*.?> match this text\.";
string input = @"<html><body>
This is the start.
<a href=""http://example.com/path"">We don't want to match this text.</a>
<a href=""http://www.example.com/another/path"" style=""font-family:Arial, Helvetica, 'sans-serif'; color:#838383;font-size:12px; line-height:14px""></a> match this text.<a href=""blah"">We also don't want to match this text</a>
</body></html>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}