package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)<a[^>]+href=["'](?P<link>.*?)["']*.?> match this text\.`)
var str = `<html><body>
This is the start.
<a href="http://example.com/path">We don't want to match this text.</a>
<a href="http://www.example.com/another/path" style="font-family:Arial, Helvetica, 'sans-serif'; color:#838383;font-size:12px; line-height:14px"></a> match this text.<a href="blah">We also don't want to match this text</a>
</body></html>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}