use strict;
my $str = '<html><body>
This is the start.
<a href="http://example.com/path">We don\'t want to match this text.</a>
<a href="http://www.example.com/another/path" style="font-family:Arial, Helvetica, \'sans-serif\'; color:#838383;font-size:12px; line-height:14px"></a> match this text.<a href="blah">We also don\'t want to match this text</a>
</body></html>';
my $regex = qr`(?is)<a[^>]+href=["'](?P<link>.*?)["']*.?> match this text\.`p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}