import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?is)<a[^>]+href=[\"'](?P<link>.*?)[\"']*.?> match this text\\.";
final String string = "<html><body>\n"
+ "This is the start. \n"
+ "<a href=\"http://example.com/path\">We don't want to match this text.</a>\n"
+ "<a href=\"http://www.example.com/another/path\" style=\"font-family:Arial, Helvetica, 'sans-serif'; color:#838383;font-size:12px; line-height:14px\"></a> match this text.<a href=\"blah\">We also don't want to match this text</a>\n"
+ "</body></html>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}