$re = '`(?is)<a[^>]+href=["\'](?P<link>.*?)["\']*.?> match this text\.`';
$str = '<html><body>
This is the start.
<a href="http://example.com/path">We don\'t want to match this text.</a>
<a href="http://www.example.com/another/path" style="font-family:Arial, Helvetica, \'sans-serif\'; color:#838383;font-size:12px; line-height:14px"></a> match this text.<a href="blah">We also don\'t want to match this text</a>
</body></html>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);