// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?is)<a[^>]+href=["'](?P<link>.*?)["']*.?> match this text\."#).unwrap();
let string = "<html><body>
This is the start.
<a href=\"http://example.com/path\">We don't want to match this text.</a>
<a href=\"http://www.example.com/another/path\" style=\"font-family:Arial, Helvetica, 'sans-serif'; color:#838383;font-size:12px; line-height:14px\"></a> match this text.<a href=\"blah\">We also don't want to match this text</a>
</body></html>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}