# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^((\b[^\s=]+)=(([^=]|\\=)+))*$//g;t' <<< "Key1=Value1 Key2=Value2"