import Foundation
let pattern = #"^((\b[^\s=]+)=(([^=]|\\=)+))*$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Key1=Value1 Key2=Value2"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)