using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((\b[^\s=]+)=(([^=]|\\=)+))*$";
string substitution = @"";
string input = @"Key1=Value1 Key2=Value2";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}