#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^((\b[^\s=]+)=(([^=]|\\=)+))*$"
Local $sString = "Key1=Value1 Key2=Value2"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)