package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((\b[^\s=]+)=(([^=]|\\=)+))*$`)
var str = `Key1=Value1 Key2=Value2`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}