use strict;
my $str = 'Key1=Value1 Key2=Value2';
my $regex = qr/^((\b[^\s=]+)=(([^=]|\\=)+))*$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";