re = /^((\b[^\s=]+)=(([^=]|\\=)+))*$/
str = 'Key1=Value1 Key2=Value2'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result