#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w+):\s+(.*)\r?\n"
Local $sString = "/*" & @CRLF & _
"title: Introduction" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"Introduction" & @CRLF & _
"============" & @CRLF & _
"" & @CRLF & _
"[This is a link](http://google.com)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"* This is a list" & @CRLF & _
"* This is a list" & @CRLF & _
"* [This is a link](http://google.com)" & @CRLF & _
"* "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")