import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+):\\s+(.*)\\r?\\n";
final String string = "/*\n"
+ "title: Introduction\n"
+ "*/\n\n"
+ "Introduction\n"
+ "============\n\n"
+ "[This is a link](http://google.com)\n\n"
+ "\n\n"
+ "* This is a list\n"
+ "* This is a list\n"
+ "* [This is a link](http://google.com)\n"
+ "* ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}