use strict;
my $str = '/*
title: Introduction
*/
Introduction
============
[This is a link](http://google.com)

* This is a list
* This is a list
* [This is a link](http://google.com)
* ';
my $regex = qr/(\w+):\s+(.*)\r?\n/mp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}