$re = '/(\w+):\s+(.*)\r?\n/m';
$str = '/*
title: Introduction
*/
Introduction
============
[This is a link](http://google.com)

* This is a list
* This is a list
* [This is a link](http://google.com)
* ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);