import Foundation
let pattern = #"(\w+):\s+(.*)\r?\n"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/*
title: Introduction
*/
Introduction
============
[This is a link](http://google.com)

* This is a list
* This is a list
* [This is a link](http://google.com)
* 
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}