using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+):\s+(.*)\r?\n";
string input = @"/*
title: Introduction
*/
Introduction
============
[This is a link](http://google.com)

* This is a list
* This is a list
* [This is a link](http://google.com)
* ";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}