#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?us)<div class="container">(.+?)\n<\/div>"
Local $sString = "<div class="container">" & @CRLF & _
" <div class="box">" & @CRLF & _
" ..... (some code)" & @CRLF & _
" </div>" & @CRLF & _
" <div class="box">" & @CRLF & _
" ..... (some code)" & @CRLF & _
" </div>" & @CRLF & _
" <div class="box">" & @CRLF & _
" ..... (some code)" & @CRLF & _
" </div>" & @CRLF & _
" <div class="box">" & @CRLF & _
" ..... (some code)" & @CRLF & _
" </div>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")