using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div class=""container"">(.+?)\n<\/div>";
string input = @"<div class=""container"">
<div class=""box"">
..... (some code)
</div>
<div class=""box"">
..... (some code)
</div>
<div class=""box"">
..... (some code)
</div>
<div class=""box"">
..... (some code)
</div>
</div>";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}