const regex = /<div class="container">(.+?)\n<\/div>/us;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div class="container">(.+?)\\n<\\\/div>', 'us')
const str = `<div class="container">
<div class="box">
..... (some code)
</div>
<div class="box">
..... (some code)
</div>
<div class="box">
..... (some code)
</div>
<div class="box">
..... (some code)
</div>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}