re = /<div class="container">(.+?)\n<\/div>/
str = '<div class="container">
<div class="box">
..... (some code)
</div>
<div class="box">
..... (some code)
</div>
<div class="box">
..... (some code)
</div>
<div class="box">
..... (some code)
</div>
</div>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end