import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div class=\"container\">(.+?)\\n<\\/div>";
final String string = "<div class=\"container\">\n"
+ " <div class=\"box\">\n"
+ " ..... (some code)\n"
+ " </div>\n"
+ " <div class=\"box\">\n"
+ " ..... (some code)\n"
+ " </div>\n"
+ " <div class=\"box\">\n"
+ " ..... (some code)\n"
+ " </div>\n"
+ " <div class=\"box\">\n"
+ " ..... (some code)\n"
+ " </div>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}