$re = '/<div class="container">(.+?)\n<\/div>/us';
$str = '<div class="container">
<div class="box">
..... (some code)
</div>
<div class="box">
..... (some code)
</div>
<div class="box">
..... (some code)
</div>
<div class="box">
..... (some code)
</div>
</div>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);