#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?<=\w)[A-Z])(?!(?:[^"]*"[^"]*")*[^"]*$)"
Local $sString = ".Label("ATextWhichHasCapitalLetters")" & @CRLF & _
".Label(Constants.DefinedLabel)" & @CRLF & _
".Label("AnotherTextWhichHasCapitalLetters")"
Local $sSubst = " $1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)