const regex = /((?<=\w)[A-Z])(?!(?:[^"]*"[^"]*")*[^"]*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?<=\\w)[A-Z])(?!(?:[^"]*"[^"]*")*[^"]*$)', 'gm')
const str = `.Label("ATextWhichHasCapitalLetters")
.Label(Constants.DefinedLabel)
.Label("AnotherTextWhichHasCapitalLetters")`;
const subst = ` $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);