using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<=\w)[A-Z])(?!(?:[^""]*""[^""]*"")*[^""]*$)";
string substitution = @" $1";
string input = @".Label(""ATextWhichHasCapitalLetters"")
.Label(Constants.DefinedLabel)
.Label(""AnotherTextWhichHasCapitalLetters"")";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}