$re = '/((?<=\w)[A-Z])(?!(?:[^"]*"[^"]*")*[^"]*$)/m';
$str = '.Label("ATextWhichHasCapitalLetters")
.Label(Constants.DefinedLabel)
.Label("AnotherTextWhichHasCapitalLetters")';
$subst = " $1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;