import re
regex = re.compile(r"((?<=\w)[A-Z])(?!(?:[^\"]*\"[^\"]*\")*[^\"]*$)", flags=re.MULTILINE)
test_str = (".Label(\"ATextWhichHasCapitalLetters\")\n"
".Label(Constants.DefinedLabel)\n"
".Label(\"AnotherTextWhichHasCapitalLetters\")")
subst = " $1"
result = regex.sub(subst, test_str)
if result:
print(result)