re = /((?<=\w)[A-Z])(?!(?:[^"]*"[^"]*")*[^"]*$)/m
str = '.Label("ATextWhichHasCapitalLetters")
.Label(Constants.DefinedLabel)
.Label("AnotherTextWhichHasCapitalLetters")'
subst = ' $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result