use strict;
my $str = '.Label("ATextWhichHasCapitalLetters")
.Label(Constants.DefinedLabel)
.Label("AnotherTextWhichHasCapitalLetters")';
my $regex = qr/((?<=\w)[A-Z])(?!(?:[^"]*"[^"]*")*[^"]*$)/mp;
my $subst = ' $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";