#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?:\s*<meta\s*property=["']og:.+?["']\s*content=["'].+?["']\s*\/>\s*)+$"
Local $sString = "<meta property="og:[anything]" content="[anything]"/>" & @CRLF & _
"" & @CRLF & _
"<meta property="og:[anything]" " & @CRLF & _
" content="[anything]"/>" & @CRLF & _
"" & @CRLF & _
"<meta " & @CRLF & _
" property="og:[anything]" " & @CRLF & _
" content="[anything]"" & @CRLF & _
"/>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<meta property="og:blargh his" content="{test: bloop'"}"/>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")