re = /^(?:\s*<meta\s*property=["']og:.+?["']\s*content=["'].+?["']\s*\/>\s*)+$/
str = '<meta property="og:[anything]" content="[anything]"/>
<meta property="og:[anything]"
content="[anything]"/>
<meta
property="og:[anything]"
content="[anything]"
/>
<meta property="og:blargh his" content="{test: bloop\'"}"/>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end