import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\s*<meta\\s*property=[\"']og:.+?[\"']\\s*content=[\"'].+?[\"']\\s*\\/>\\s*)+$";
final String string = "<meta property=\"og:[anything]\" content=\"[anything]\"/>\n\n"
+ "<meta property=\"og:[anything]\" \n"
+ " content=\"[anything]\"/>\n\n"
+ "<meta \n"
+ " property=\"og:[anything]\" \n"
+ " content=\"[anything]\"\n"
+ "/>\n\n\n"
+ "<meta property=\"og:blargh his\" content=\"{test: bloop'\"}\"/>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}