using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\s*<meta\s*property=[""']og:.+?[""']\s*content=[""'].+?[""']\s*\/>\s*)+$";
string input = @"<meta property=""og:[anything]"" content=""[anything]""/>
<meta property=""og:[anything]""
content=""[anything]""/>
<meta
property=""og:[anything]""
content=""[anything]""
/>
<meta property=""og:blargh his"" content=""{test: bloop'""}""/>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}