import Foundation
let pattern = #"^(?:\s*<meta\s*property=["']og:.+?["']\s*content=["'].+?["']\s*\/>\s*)+$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<meta property="og:[anything]" content="[anything]"/>
<meta property="og:[anything]"
content="[anything]"/>
<meta
property="og:[anything]"
content="[anything]"
/>
<meta property="og:blargh his" content="{test: bloop'"}"/>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}