$re = '/^(?:\s*<meta\s*property=["\']og:.+?["\']\s*content=["\'].+?["\']\s*\/>\s*)+$/';
$str = '<meta property="og:[anything]" content="[anything]"/>
<meta property="og:[anything]"
content="[anything]"/>
<meta
property="og:[anything]"
content="[anything]"
/>
<meta property="og:blargh his" content="{test: bloop\'"}"/>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);