package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:\s*<meta\s*property=["']og:.+?["']\s*content=["'].+?["']\s*\/>\s*)+$`)
var str = `<meta property="og:[anything]" content="[anything]"/>
<meta property="og:[anything]"
content="[anything]"/>
<meta
property="og:[anything]"
content="[anything]"
/>
<meta property="og:blargh his" content="{test: bloop'"}"/>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}